Page 1 of 2

Supported Chromium Version

Posted: Thu Jan 24, 2019 5:22 pm
by Manuel
Hi

I'm trying to run an electron application but the On-Demand Keyboard keeps popping up.

Seems like its an chromium issue.

My current Electron build uses Chromium 61.0.3163.100.
I than tried the latest Electron Version, which uses Chromium 69.0.3497.106.
Electron Version 5.0.0-beta.1 (using Chromium 72.0.3626.52) also doenst seem to work.

I am using Touch-it Keyboard Version 5.16.

Some additonal Info.
Electron app is displaying a website in an Iframe.
The Keyboard does not pop up on the Webpage in Chrome 71.0.3578.98

Any Ideas what i could do?
By the way what is your latest officaly supported Chromium version?

Re: Supported Chromium Version

Posted: Fri Jan 25, 2019 12:00 pm
by chessware
Could you send us a test app?

We have no official supported Chromium version. It is the responsibility of the Chromium project to be compliant with accessibility API.
This said, Touch-It v5.16 works pretty well with Chrome Canary v73 despite many issues still need to be fixed by the Chromium team (eg. input fields in <map> elements are not managed at all).

Re: Supported Chromium Version

Posted: Tue Feb 05, 2019 11:20 am
by Manuel
Hi
Sorry for the late response

I uploaded the TestApps here. They should be available until end of next week.

https://wetransfer.com/downloads/f0570c ... 811/daadac

Apps include Electron 2.0.2, 4.0.3, 5.0.1 and all of these Version again with an Iframe and Input field

I also did some digging myself
TouchIt Version 5.12 seems to be working in all cases but 5.16 does not
5.16 does not like IFrames it seems.

Hope this helps helping me

Kind Regards

Manu

Re: Supported Chromium Version

Posted: Fri Feb 08, 2019 11:09 am
by Manuel
Any Infos or possible solutions?

Re: Supported Chromium Version

Posted: Fri Feb 08, 2019 1:13 pm
by chessware
Yes, we have fixed this issue. Thank you very much for having provided test cases.
A downloadable version will be available next week.

Re: Supported Chromium Version

Posted: Mon Feb 11, 2019 2:06 pm
by Tobias Lutz
Hi

Please send us notifcation when new version is available.
We need it very urgently, because of at customer site installed systems which are not running now.

Thank you!
Tobias Lutz
Product Manager

Re: Supported Chromium Version

Posted: Mon Feb 11, 2019 2:36 pm
by chessware
We will.

The delay is caused by a certificate renewal (to sign our coding) which takes several days to complete.

Re: Supported Chromium Version

Posted: Fri Feb 15, 2019 11:19 am
by chessware
Sorry for the delay.

Touch-It 5.17 beta 2 is now ready for download.

Re: Supported Chromium Version

Posted: Fri Feb 22, 2019 9:48 am
by Andy
Ive Tested the Beta with 3 other Apps and everything looks good so far.

Is it planing to push the changes in the next Stable Release?

OT: The Tutorial section Link seems to be broken, was looking for how-to on how to create customized skins (viewforum.php?f=18)

Kindly regards

Re: Supported Chromium Version

Posted: Fri Feb 22, 2019 9:52 am
by chessware
Yes it will.